1С Режим Конфигуратор

Компания Русский электрик - электромонтажные работы в коттедже Новосибирск и пригороде.

99 - часть 4


  Если ФлагПоЖурналам=1 Тогда

    ЗакладкиОтбора("НомерЖурнала",1);

  Иначе

    ЗакладкиОтбора("",1);

  КонецЕсли;

КонецПроцедуры

2.29 Снова Операция.

После определения всех реквизитов проводок можно перейти к созданию формы Операции. Вернемся в окно редактирования свойств объекта метаданных Операция. Вызовем окно редактирования формы операции. Расставим реквизиты формы поприличнее.


Напишем в модуле формы процедуру:

Процедура ПриОткрытии()

  ИспользоватьВалюту(Константа.ОснВалюта);

// Здесь мы указываем, что в форме операции по умолчанию использовать основную

// валюту

КонецПроцедуры


Создадим и форму списка операций, самого простого вида.

Глава 6

2.30 Документы. Общая часть.

План счетов создан, операции и проводки готовы, теперь можно и заняться документами. Давайте определим общие реквизиты документов и нумераторы.

Каждый документ относится к какой-либо фирме – это первый общий реквизит. Мы хотим к каждому документу приписать пояснение – это будет вторым общим реквизитом. Все документы у нас будут связаны с деньгами, а деньги обычно относятся к какой-нибудь валюте – третий общий реквизит – валюта. Валюта имеет по отношению к базовой валюте на каждую дату свой курс – еще два общих реквизита: дата курса и курс. Еще нас будет интересовать кто создал этот документ – и еще один общий реквизит автор.

Идентификатор

Тип значения

Дополнительно

ФирмаДокумента

С.Фирмы

О

Пояснение

Строка 100

Валюта

С.Валюты

ДатаКурса

Дата

Курс

Число 6.2

АвторДокумента

Строка 50

О

"О" - отбор

Нумераторов у нас не будет. Каждый документ будет иметь свою независимую нумерацию.

2.31 Документ УчетНДС.

Первый и самый простой документ будет Учет НДС. Проводка по нему самая простая (Д 68.1 – К 19.3). Этим документом мы будем переводить сумму НДС за приобретенные комплектующие в зачет налогов. Документ будет относиться к специальному журналу "УчетНДС". Журнал обычный. В журнале заведем графу "Сумма", значение для нее будем брать Документ.УчетНДС.Сумма.

Идентификатор: УчетНДС

Журнал: УчетНДС

Нумератор: Нет       Периодичность: Год

Длина: 5         Тип: число

Уникальность: да       Автонумерация: да

Может являться основанием для документа любого вида?: нет

Проводить: да

Автоматическое удаление движений: да

Автоматическая нумерация строк: да

Бухгалтерский учет: да

Расчет: нет

Оперативный учет: нет

Создавать операцию: Всегда       Редактировать операцию: нет




- Начало -  - Назад -  - Вперед -



Книжный магазин