1С Режим Конфигуратор


Дополнение


Товар

Товар

С.Номенклатура

Сорт

Сорт товара

С.Сорт

Кол

Количество в произвольной ед. измерения

Число 8.2

+

Ед

Единица измерения

С.Единицы

КолО

Количество в основной ед. измерения

Число 8.2

+,И

Цена

Цена реализации

Число 7.2

+

Сумма

Сумма документа

Число 15.2

+,И

 

  1. Создадим новый документ;
  2. Заполняем свойства и реквизиты согласно таблицы;
  3. Создаем форму документа;
  4. Редактируем форму накладной по аналогии с приходной накладной;
  5. Поле реквизита "НомерДок" делаем недоступным для редактирования;
  6. Формулы в реквизиты диалога ставим такие же как и в приходной накладной. За исключением Поставщик(), ее заменяем на Покупатель(). И убираем процедуру из колонки "Цена", эту колонку делаем недоступной для редактирования;
  7. Процедуры в модуль документа заносим из модуля формы приходной накладной. Только везде ЦенаП меняем на ЦенаР, и меняем название процедуры Поставщик() на Покупатель(), и убираем процедуру Цена();
  8. Текстовые поля с итогами по колонкам таблицы можно просто скопировать из формы документа приходная накладная;

У нас цена реализации зависит от даты. Мы хотим, чтобы при изменении даты документа цены в строках документа соответственно менялись;

  1. Добавим функцию ДатаДок() в поле реквизита "ДатаДок";
  2. В модуль формы добавим процедуру:

    Процедура ДатаДок()

      ВыбратьСтроки();

      Пока ПолучитьСтроку()=1 Цикл

        Если Сорт.Выбран()=1 Тогда

          Цена=Окр(Товар.ЦенаР.Получить(ДатаДок)*(Сорт.Процент/100),2,1);

          Сумма=Окр(КолО*Цена,2,1);

        Иначе

          Цена=0;

          Сумма=0;

        КонецЕсли;

      КонецЦикла;

    КонецПроцедуры

    // Процедура простая и в комментариях не нуждается

    При заполнении накладной нам надо помнить, чего сколько на каком складе у нас лежит. В 1С для такой ситуации есть специальный механизм подбора. Реализуем его в нашей расходной накладной. Но сперва, для подбора, создадим особую форму списка справочника товаров.




  3. - Начало -  - Назад -  - Вперед -



    Книжный магазин