1С Режим Конфигуратор


Дополнение - часть 11


      Регистр.ОборотыТоваров.ДвижениеВыполнить();

    КонецЦикла;

  КонецЕсли;

КонецПроцедуры

Здесь мы переставили алгоритмы списания местами, в расходной накладной при списании по методу FIFO мы использовали алгоритм выгрузки регистра, а LIFO – запрос, то теперь наоборот, с соответствующими изменениями.

  • Внесем дополнения по аналогии с другими накладными в журнал "Накладные";
  • Войдем в окно редактирования документа "ПриходнаяНакладная";
  • [Ввод на основании...];
  • Может являться основанием для документа любого вида – Нет;
  • Сохраним конфигурацию;
  • Войдем в 1С:Предприятие;
  • Сделаем нашу расходную накладную не проведенной;
  • Установим способ списания – FIFO;
  • На основании приходной накладной №7 введем накладную на перемещение. Для этого установим в журнале курсор на нужном документе. Меню Действия команда "Ввести на основании";
  • Создалась уже почти заполненная накладная на перемещение №2 от 08.10.2000;
  • Укажем склад получатель – Склад №2;
  • Проведем накладную;
  • Посмотрим на движения. Хоть мы и указали как основание накладную №7, у нас списалось с более ранней накладной №6. Как написали алгоритм списания – так и получилось. Отсюда мораль: "Программа делает не то, что хочешь, а то, что напишешь!";
  • Глава 9

    2.25 Оборотные ведомости.

    Документом "Накладная на перемещение " мы завершили создание системы учета остатков на складах и товарооборота. Но учет не имеет смысла без отчетности. У нас уже есть отчеты, которые показывают состояние остатков и долгов на конкретную дату. Создадим два отчета: один нам покажет изменение долгов за какой-то период, а второй движение по складу товаров.

    1. Создаем новый отчет "ОбороткаПоДолгам";
    2. Добавим поле ввода ДатаН – тип Дата, формула ДатаН();
    3. Добавим поле ввода ДатаК – тип Дата, формула ДатаК();

    4. Пропишем процедуры в модуле формы:

      Процедура ДатаН()

        Если ДатаН>ДатаК Тогда

          ДатаН=ДатаК;

        КонецЕсли;

      КонецПроцедуры




      - Начало -  - Назад -  - Вперед -



      Книжный магазин