1С Режим Конфигуратор


Дополнение - часть 13


    КонОст=Запрос.СуммаКонОст;

    Если Контра.ЭтоГруппа()=1 Тогда

      Таб.ВывестиСекцию("Группа");

    Иначе

      Таб.ВывестиСекцию("Контра");

      Пока Запрос.Группировка(2)=1 Цикл

        Дог=Запрос.Догов;

        НачОст=Запрос.СуммаНачОст;

        ПрихТов=Запрос.СуммаПриходТов;

        РасхДен=Запрос.СуммаРасходДен;

        РасхТов=Запрос.СуммаРасходТов;

        ПрихДен=Запрос.СуммаПриходДен;

        КонОст=Запрос.СуммаКонОст;

        Таб.ВывестиСекцию("Дог");

      КонецЦикла;

    КонецЕсли;

  КонецЦикла;

  Таб.ВывестиСекцию("Итого");

  Таб.ТолькоПросмотр(1);

  Таб.ПараметрыСтраницы(1,100,1);

  Таб.Показать("");

КонецПроцедуры

  • Создадим шаблон печатной формы;

  • Сохраним конфигурацию;
  • Создаем новый отчет "ОбороткаПоСкладу";
  • Добавим поле ввода ДатаН – тип Дата, формула ДатаН();
  • Добавим поле ввода ДатаК – тип Дата, формула ДатаК();
  • Добавим поле ввода Склад – тип С.Склады;

  • Пропишем процедуры в модуле формы:

    //-----------------------------------------------

    Процедура ДатаН()

      Если ДатаН>ДатаК Тогда

        ДатаН=ДатаК;

      КонецЕсли;

    КонецПроцедуры

    //-----------------------------------------------

    Процедура ДатаК()

      Если  ДатаК<ДатаН Тогдаbr>     ДатаК=ДатаН;

      ИначеЕсли ДатаК>ПолучитьДатуТА() Тогда

        ДатаК=ПолучитьДатуТА();

      КонецЕсли;

    КонецПроцедуры

    //-----------------------------------------------

    Процедура Сформировать()

      Если Склад.Выбран()=0 Тогда

        Сообщить("Не выбран склад");

        Возврат;

      КонецЕсли;

      Запрос=СоздатьОбъект("Запрос");

      ТекстЗапроса="




    - Начало -  - Назад -  - Вперед -