1С Режим Конфигуратор


Дополнение - часть 15


      ПриходК = Запрос.КолПриходК;

      ПриходВ = Запрос.КолПриходВ;

      РасходВ = Запрос.КолРасходВ;

      РасходК = Запрос.КолРасходК;

      КонОстС = Запрос.КолКонОстС;

      Таб.ВывестиСекцию("Товар");

      Пока Запрос.Группировка("Сорт")=1 Цикл

        Срт=Запрос.Сорт;

        НачОстС = Запрос.КолНачОстС;

        ПриходК = Запрос.КолПриходК;

        ПриходВ = Запрос.КолПриходВ;

        РасходВ = Запрос.КолРасходВ;

        РасходК = Запрос.КолРасходК;

        КонОстС = Запрос.КолКонОстС;

        Таб.ВывестиСекцию("Сорт");

      КонецЦикла;

    КонецЕсли;

  КонецЦикла;

  Таб.ВывестиСекцию("Итого");

  Таб.ТолькоПросмотр(1);

  Таб.ПараметрыСтраницы(1,100,1);

  Таб.Показать("");

КонецПроцедуры

Во многом модуль этого отчета похож на предыдущий.

  • Создадим шаблон печатной формы;

  • Сохраним изменения в конфигурации;
  • Загрузим 1С:Предприятие;
  • Создадим несколько новых документов, проведем старые и посмотрим, что выдадут нам наши отчеты;
  • 2.26 Отчет по прибыли с товара.

    В регистре "ОстаткиТовара" мы хранили такую информацию, как сумма поступления и сумма реализации. Создадим отчет, показывающий прибыль, которую мы получили в результате нашей хозяйственной деятельности.

    1. Создаем новый отчет "Прибыль";
    2. Добавим поле ввода ДатаН – тип Дата, формула ДатаН();
    3. Добавим поле ввода ДатаК – тип Дата, формула ДатаК();
    4. Добавим поле ввода Склад – тип С.Склады;
    5. Добавим кнопку [Х]. Пропишем в поле Формула свойств кнопки Склад="", этой кнопкой мы будем очищать поле "Склад";

    6. Пропишем процедуры в модуле формы:

      Процедура ДатаН()

        Если ДатаН>ДатаК Тогда




      - Начало -  - Назад -  - Вперед -