1С Режим Конфигуратор


Дополнение - часть 16


    ДатаН=ДатаК;

  КонецЕсли;

КонецПроцедуры

//-----------------------------------------------

Процедура ДатаК()

  Если  ДатаК<ДатаН Тогдаbr>     ДатаК=ДатаН;

  ИначеЕсли ДатаК>ПолучитьДатуТА() Тогда

    ДатаК=ПолучитьДатуТА();

  КонецЕсли;

КонецПроцедуры

//-----------------------------------------------

Процедура Сформировать()

  Запрос=СоздатьОбъект("Запрос");

  ТекстЗапроса="

  |Период с ДатаН по ДатаК;

  |Скл = Регистр.ОстаткиТоваров.Склад;

  |Товар = Регистр.ОстаткиТоваров.Товар;

  |Сорт = Регистр.ОстаткиТоваров.Сорт;

  |Количество = Регистр.ОстаткиТоваров.Количество;

  |СуммаП = Регистр.ОстаткиТоваров.СуммаП;

  |СуммаД = Регистр.ОстаткиТоваров.СуммаД;

  |Ф = Регистр.ОстаткиТоваров.ФлагДвижения;

  |Функция КоличРасходС = Расход(Количество) когда(Ф=1);

  |Функция СуммаПРасход = Расход(СуммаП) когда(Ф=1);

  |Функция СуммаДРасход = Расход(СуммаД) когда(Ф=1);

  |Группировка Товар упорядочить по Товар.Код без групп;

  |Группировка Сорт упорядочить по Сорт.Код;";

// Мы не хотим в запросе получать группы товара (для примера)

  СклТекст="По всем складам";

  Если Склад.Выбран()=1 Тогда

    СклТекст="По складу: "+СокрЛП(Склад.Наименование);

    ТекстЗапроса=ТекстЗапроса+"

    |Условие(Скл=Склад);";

  КонецЕсли;

  Если Запрос.Выполнить(ТекстЗапроса)=0 Тогда

    Сообщить("Запрос не выполнен");

    Возврат;

  КонецЕсли;

  Таб=СоздатьОбъект("Таблица");

  Таб.ИсходнаяТаблица("");

  ИтКолРасх = Запрос.КоличРасходС;

  ИтСумПРас = Запрос.СуммаПРасход;

  ИтСумДРас = Запрос.СуммаДРасход;

  ИтПрибыль = ИтСумДРас-ИтСумПРас;

  Таб.ВывестиСекцию("Шапка");

  Пока Запрос.Группировка("Товар")=1 Цикл




- Начало -  - Назад -  - Вперед -