1С Режим Конфигуратор


Дополнение - часть 17


    ТТов=Запрос.Товар;

    Тов=СокрЛП(ТТов.Код)+" ("+СокрЛП(ТТов.Наименование)+")";

    КолРасх = Запрос.КоличРасходС;

    СумПРас = Запрос.СуммаПРасход;

    СумДРас = Запрос.СуммаДРасход;

    Прибыль = СумДРас-СумПРас;

    Таб.ВывестиСекцию("Товар");

    Пока Запрос.Группировка("Сорт")=1 Цикл

      Срт=Запрос.Сорт;

      КолРасх = Запрос.КоличРасходС;

      СумПРас = Запрос.СуммаПРасход;

      СумДРас = Запрос.СуммаДРасход;

      Прибыль = СумДРас-СумПРас;

      Таб.ВывестиСекцию("Сорт");

    КонецЦикла;

  КонецЦикла;

  Таб.ВывестиСекцию("Итого");

  Таб.ТолькоПросмотр(1);

  Таб.ПараметрыСтраницы(1,100,1);

  Таб.Показать("");

КонецПроцедуры

  • Создадим шаблон печатной формы;

  • 2.27 Отчет по обороту товара.

    Сформируем отчет по товарообороту. Для него мы возьмем данные из регистра "ОборотыТоваров".

    1. Создаем новый отчет "ТоварооборотПоСкладу";
    2. Добавим поле ввода ДатаН – тип Дата, формула ДатаН();
    3. Добавим поле ввода ДатаК – тип Дата, формула ДатаК();
    4. Добавим поле ввода Склад – тип С.Склады;
    5. Добавим кнопку [Х]. Пропишем в поле Формула свойств кнопки Склад="", этой кнопкой мы будем очищать поле "Склад";

    6. Пропишем процедуры в модуле формы:

      //-----------------------------------------------

      Процедура ДатаН()

        Если ДатаН>ДатаК Тогда

          ДатаН=ДатаК;

        КонецЕсли;

      КонецПроцедуры

      //-----------------------------------------------

      Процедура ДатаК()

        Если  ДатаК<ДатаН Тогдаbr>     ДатаК=ДатаН;

        ИначеЕсли ДатаК>ПолучитьДатуТА() Тогда

          ДатаК=ПолучитьДатуТА();

        КонецЕсли;

      КонецПроцедуры

      //-----------------------------------------------

      Процедура Сформировать()




      - Начало -  - Назад -  - Вперед -



      Книжный магазин