1С Режим Конфигуратор


Дополнение - часть 18


  Запрос=СоздатьОбъект("Запрос");

  ТекстЗапроса="

  |Период с ДатаН по ДатаК;

  |Скл = Регистр.ОборотыТоваров.Склад;

  |Тов = Регистр.ОборотыТоваров.Товар;

  |Срт = Регистр.ОборотыТоваров.Сорт;

  |Кол = Регистр.ОборотыТоваров.Количество;

  |Сум = Регистр.ОборотыТоваров.СуммаУ;

  |Функция КолСум = Сумма(Кол);

  |Функция СумСум = Сумма(Сум);

  |Группировка Тов упорядочить по Тов.Код без групп;

  |Группировка Срт упорядочить по Сорт.Код;";

  СклТекст="По всем складам";

  Если Склад.Выбран()=1 Тогда

    СклТекст="По складу: "+СокрЛП(Склад.Наименование);

    ТекстЗапроса=ТекстЗапроса+"

    |Условие(Скл=Склад);";

  КонецЕсли;

  Если Запрос.Выполнить(ТекстЗапроса)=0 Тогда

    Сообщить("Запрос не выполнен");

    Возврат;

  КонецЕсли;

  Таб=СоздатьОбъект("Таблица");

  Таб.ИсходнаяТаблица("");

  ИтКолСум = Запрос.КолСум;

  ИтСумСум = Запрос.СумСум;

  Таб.ВывестиСекцию("Шапка");

  Пока Запрос.Группировка("Товар")=1 Цикл

    ТТов=Запрос.Товар;

    Тов=СокрЛП(ТТов.Код)+" ("+СокрЛП(ТТов.Наименование)+")";

    КолСум = Запрос.КолСум;

    СумСум = Запрос.СумСум;

    Таб.ВывестиСекцию("Товар");

    Пока Запрос.Группировка("Сорт")=1 Цикл

      Срт=Запрос.Сорт;

      КолСум = Запрос.КолСум;

      СумСум = Запрос.СумСум;

      Таб.ВывестиСекцию("Сорт");

    КонецЦикла;

  КонецЦикла;

  Таб.ВывестиСекцию("Итого");

  Таб.ТолькоПросмотр(1);

  Таб.ПараметрыСтраницы(1,100,1);

  Таб.Показать("");

КонецПроцедуры

  • Создадим шаблон печатной формы;

  • Теперь мы можем загрузить 1С:Предприятие и посмотреть, что нам выдадут наши отчеты;



  • - Начало -  - Назад -  - Вперед -



    Книжный магазин