1С Режим Конфигуратор




Дополнение - часть 3


    |не проведен.

    |Не выбран склад получатель");

// Делаем сообщение

    НеПроводитьДокумент();

// Указываем, что документ проводить не надо

    Возврат;

// Выходим из процедуры

  КонецЕсли;

  Если Поставщик.Выбран()=0 Тогда

    Сообщить("Документ Приходная накладная №"+НомерДок+" от "+ДатаДок+"

    |не проведен.

    |Не выбран поставщик");

    НеПроводитьДокумент();

    Возврат;

  КонецЕсли;

  КурсД=Курс;

  КратД=Валюта.Кратность;

  КурсУ=Константа.ОснВалюта.Курс.Получить(ДатаДок);

  КратУ=Константа.ОснВалюта.Кратность;

  Коэфф=Окр((КурсД*КратУ)/(КурсУ*КратД),6,1);

// Переводим в валюту документа

  ВыбратьСтроки();

  Пока ПолучитьСтроку() = 1 Цикл

// Обходим строки

    ПривязыватьСтроку(НомерСтроки);

// Здесь мы хотим указать какая строка документа вызвала эту проводку

    Операция.НоваяПроводка();

    Операция.Дебет.Счет = СчетПоКоду("10.2",ПланыСчетов.Наш);

    Операция.Дебет.МестоХранения = Склад;

    Операция.Дебет.Комплектующее = Товар;

    Операция.Дебет.ПриходнаяНакладная = ТекущийДокумент();

    Операция.Кредит.Счет = СчетПоКоду("60",ПланыСчетов.Наш);

    Операция.Кредит.Контрагент = Поставщик;

    Операция.Кредит.ПриходнаяНакладная = ТекущийДокумент();

    Операция.Количество = Кол;

    Операция.Сумма = Окр(СуммаБНДС*Коэфф,2,1);

    Операция.Фирма = ФирмаДокумента;

    Операция.Комментарий = "Поступление комплектующих";

    Операция.НомерЖурнала = "6";

  КонецЦикла;

  ПривязыватьСтроку(0);

// Эта проводка по всему документу вцелом

  Операция.НоваяПроводка();

  Операция.Дебет.Счет = СчетПоКоду("19.3",ПланыСчетов.Наш);

  Операция.Кредит.Счет = СчетПоКоду("60",ПланыСчетов.Наш);




Содержание  Назад  Вперед