1С Режим Конфигуратор



Дополнение - часть 3


Вводим новый отчет "ОстаткиГотовойПродукции".

В модуль формы пишем:

Процедура ПриОткрытии()

  ДатО = РабочаяДата();

КонецПроцедуры

//==========================================================

Процедура Сформировать()

  Таб = СоздатьОбъект("Таблица");

  Таб.ИсходнаяТаблица("Таблица");

  Ит = СоздатьОбъект("БухгалтерскиеИтоги");

  Ит.ИспользоватьПланСчетов(ПланыСчетов.Наш);

  Ит.ИспользоватьРазделительУчета(Константа.ОснФирма);

  Скл="По всем складам";

  Суб=1;

  Если ВСклад.Выбран()=1 Тогда

    Ит.ИспользоватьСубконто(ВидыСубконто.МестоХранения,ВСклад,2);

    Скл="По складу: "+СокрЛП(Строка(ВСклад));

    Суб=2;

  КонецЕсли;

  Ит.ИспользоватьСубконто(ВидыСубконто.Изделие,,1);

  Ит.ВыполнитьЗапрос(,ДатО,"40");

  Таб.ВывестиСекцию("Шапка");

  ИтКол=0;

  ИтСумС=0;

  ИтСумР=0;

  ИтСумН=0;

  Ит.ВыбратьСубконто(Суб);

  Пока Ит.ПолучитьСубконто(Суб)=1 Цикл

    Изд=Ит.Субконто(Суб);

    Цен=Изд.Цена.Получить(ДатО);

    Кол=Ит.СКД(3);

    СумС=Ит.СКД(1);

    СумР=Окр(Кол*Цен,2,1);

    СумН=Окр(СумР*(1+Изд.НДС.Значение/100),2,1);

    ИтКол=ИтКол+Кол;

    ИтСумС=ИтСумС+СумС;

    ИтСумР=ИтСумР+СумР;

    ИтСумН=ИтСумН+СумН;

    Таб.ВывестиСекцию("Строка");

  КонецЦикла;

  Таб.ВывестиСекцию("Подвал");

  Таб.ТолькоПросмотр(1);

  Таб.ПараметрыСтраницы(2);

  Таб.Показать("Сформировать","");

КонецПроцедуры

Делаем шаблон печатной формы

2.43 Отчет по покупателям.

Создадим теперь отчет по 62-ому счету - "Покупатели". В поле ДатН пишем формулу Дат("Н"), а в поле ДатК – Дат("К"). В модуль формы:

Процедура Сформировать()

  Запрос=СоздатьОбъект("Запрос");




Содержание  Назад  Вперед