1С Режим Конфигуратор




Дополнение - часть 5


  Если СравнитьТА()=-1 Тогда

// Проверяем, не проводится ли документ ранее точки актуальности итогов

    РегОст.ВременныйРасчет(1);

    РассчитатьРегистрыНа(ТекущийДокумент());

  КонецЕсли;

// Проверка на наличие на остатке

  ВыбратьСтроки();

  ФлагОтказа=0;

  Пока (ПолучитьСтроку()>0) Цикл

    Остат=РегОст.СводныйОстаток(Склад,Товар,Сорт,,"Количество");

    Если Остат

      Сообщить("Нет товара № "

+СокрЛП(Товар.Код)+"/"

+СокрЛП(Сорт.Наименование)+" в колич. "

+КолО+" (имеется "+Остат+")");

      ФлагОтказа=1;

    КонецЕсли;

  КонецЦикла;

// аналогичную часть кода см. в отчете ОстаткиНаСкладе

  Если ФлагОтказа=1 Тогда

    НеПроводитьДокумент();

    Возврат;

  КонецЕсли;

// Это см. документы Приход/Расход денег

// По регистру взаиморасчетов

  Регистр.Взаиморасчеты.Контрагент = Покупатель;

  Регистр.Взаиморасчеты.Договор = Договор;

  Регистр.Взаиморасчеты.Сумма = Итог("Сумма");

  Регистр.Взаиморасчеты.ФлагДвижения = 2;

  Регистр.Взаиморасчеты.ДвижениеРасходВыполнить();

  Если Константа.МетодСписания=Перечисление.МетодСписания.ФИФО Тогда

// Здесь будет записана методика списания по FIFO

  ИначеЕсли Константа.МетодСписания=Перечисление.МетодСписания.ЛИФО

                                                        Тогда

// Здесь будет записана методика списания по LIFO

  ИначеЕсли

    Константа.МетодСписания=Перечисление.МетодСписания.По_среднему

                                                        Тогда




Содержание  Назад  Вперед