1С Режим Конфигуратор



Дополнение - часть 7


          ПривязыватьСтроку(НС);

          Операция.НоваяПроводка();

          Операция.Дебет.Счет = СчетПоКоду("20",ПланыСчетов.Наш);

          Операция.Кредит.Счет = СчетПоКоду("10.2",ПланыСчетов.Наш);

          Операция.Дебет.ВидЗатрат = Перечисление.ВидыЗатрат.НаКомплектующие;

          Операция.Дебет.Изделие = Изделие;

          Операция.Дебет.НарядНаКомплектацию = ТекущийДокумент();

          Операция.Кредит.МестоХранения = Склад;

          Операция.Кредит.Комплектующее = Ком;

          Операция.Кредит.ПриходнаяНакладная = ДокП;

          Операция.Фирма = ФирмаДокумента;

          Операция.Комментарий = "Передача комплектующих на сборку";

          Операция.НомерЖурнала = "10";

          Операция.Сумма = СумО;

          Операция.Количество = Колич;

          СуммаОпер=СуммаОпер+СумО;

// Накапливаем сумму операции по каждой проводке

          Прервать;

// Все кончилось, больше партии по этому комплектующему обходить незачем

        КонецЕсли;

      КонецЦикла; // По Партии

    КонецЦикла; // По Комплектующей

  КонецЦикла; // По Изделию

  Операция.Содержание = "Запуск производства";

  Операция.СуммаОперации = СуммаОпер;

  Операция.Автор = АвторДокумента;

  Операция.Записать();

КонецПроцедуры

Вроде бы все. Но этот механизм не будет правильно списывать партии в том случае, если в документе будут разные изделия, содержащие одинаковые комплектующие. Это показывает разницу в алгоритмическом подходе при использовании компонент Оперативный учет и Бухгалтерский учет. В Оперативном учете можно проводя строки документа все время отслеживать меняющиеся остатки, а в Бухгалтерском учете операция формируется в самом конце.




Содержание  Назад  Вперед