1С Режим Конфигуратор



Дополнение - часть 8


  Пока ТабЗн.ПолучитьСтроку()=1 Цикл

    Товар=ТабЗн.Товар;

    Тов=СокрЛП(Товар.Код)+" ("+СокрЛП(Товар.Наименование)+")";

    Сорт=ТабЗн.Сорт;

    Ост=ТабЗн.Ост;

    Ед=Строка(Товар.ЕдИзм);

    Если ТТовар<>Товар Тогда

// если товар из д. таблицы не совпадает с переменной ТТовар

      Таб.ВывестиСекцию("Товар");

// выводим эту секцию таблицы для печати

      ТТовар=Товар;

    Иначе

// товар совпадает, только сорт другой

      Таб.ВывестиСекцию("Сорт");

// выводим эту секцию

    КонецЕсли;

  КонецЦикла;

  Таб.ТолькоПросмотр(1);

  Таб.ПараметрыСтраницы(1,100,1);

  Таб.Показать("");

КонецПроцедуры

  • Теперь создаем шаблон для печатной таблицы;
  • Загружаем 1С:Предприятие;
  • Смотрим, что нам покажет отчет на разные даты по разным складам;
  • Глава 8

    2.21 FIFO/LIFO/По-среднему.

    Любителей футбола просим не беспокоится. Речь у нас пойдет не о FIFA, а о способах списания товара при разных системах учета. Бухгалтерам объяснять, что это такое, не нужно. Для остальных кратенько поясним.

    FIFO (First Input First Output) – это такая система, при которой ранее пришедшие партии товара списываются первыми. Цена списания – цена партии товара из которой списывают товар.

    LIFO (Last Input First Output) – а это такая система, при которой последняя пришедшая партия товара списывается в первую очередь. Цена списания – цена партии товара из которой списывают товар.

    По-среднему – здесь вообще партии не нужны. Цена списания – средняя цена остатка партий товара на складе.

    Мы должны при начале работы указать, какой системой списания мы будем в дальнейшем пользоваться. Перечень возможных систем учета мы будем держать в перечислении.

  • Создаем новый виз перечисления – "МетодСписания";
  • Добавим значения ФИФО, ЛИФО, По_Среднему. В представлении можно и латинскими буквами, а в идентификаторах – русскими, чтобы при наборе кода лишний раз язык не переключать;




    Содержание  Назад  Вперед