1С Режим Конфигуратор




Дополнение - часть 9


            Регистр.ОборотыТоваров.ПривязыватьСтроку(НомерСтроки);

            Регистр.ОборотыТоваров.ДвижениеВыполнить();

            Регистр.ОборотыТоваров.Склад = СкладП;

            Регистр.ОборотыТоваров.Товар = Товар;

            Регистр.ОборотыТоваров.Сорт = Сорт;

            Регистр.ОборотыТоваров.Количество = КолВыб;

            Регистр.ОборотыТоваров.СуммаУ = Окр(ЦенаПП*КолВыб,2,1);

            Регистр.ОборотыТоваров.ФлагДвижения = 2;

            Регистр.ОборотыТоваров.ПривязыватьСтроку(НомерСтроки);

            Регистр.ОборотыТоваров.ДвижениеВыполнить();

            КолВыб=КолВыб-Ост;

          КонецЕсли;

        КонецЕсли;

      КонецЦикла;

      ТабЗн2.УдалитьСтроки();

    КонецЦикла;

  ИначеЕсли

    Константа.МетодСписания=Перечисление.МетодСписания.По_среднему Тогда

// Здесь будет записана методика списания по-среднему

    ВыбратьСтроки();

    Пока ПолучитьСтроку() = 1 Цикл

      КолОст=РегОст.СводныйОстаток(СкладО,Товар,Сорт,,"Количество");

      СумОст=РегОст.СводныйОстаток(СкладО,Товар,Сорт,,"СуммаП");

      ЦенОст=Окр(СумОст/КолОст,2,1);

      Парт=ПолучитьПустоеЗначение("Документ.ПриходнаяНакладная");

      Регистр.ОстаткиТоваров.Склад = СкладО;

      Регистр.ОстаткиТоваров.Товар = Товар;

      Регистр.ОстаткиТоваров.Сорт = Сорт;

      Регистр.ОстаткиТоваров.Партия = Парт;

      Регистр.ОстаткиТоваров.Количество = КолО;




Содержание  Назад  Вперед