1С Режим Конфигуратор



Дополнение - часть 9


    Колич=ТабЗн.Кол;

    БухИтоги.ИспользоватьСубконто(ВидыСубконто.МестоХранения,Склад,2);

    БухИтоги.ИспользоватьСубконто(ВидыСубконто.Комплектующее,Ком,2);

    БухИтоги.ВыполнитьЗапрос(,ДатаДок,"10.2");

    КолКом=БухИтоги.СКД(3);

    Если Колич>КолКом Тогда

      ФлагОтказа=1;

      Сообщить(Строка(Ком));

    КонецЕсли;

  КонецЦикла;

  Если ФлагОтказа=1 Тогда

    Сообщить("Документ Наряд на сборку №"+НомерДок+" от "+ДатаДок+"

    |не проведен.

    |Заказ по вышеперечисленным позициям

    |превышает остаток на складе");

    НеПроводитьДокумент();

    Возврат;

  КонецЕсли;

// Без изменений

  ТабКом=СоздатьОбъект("ТаблицаЗначений");

  ТабКом.НоваяКолонка("Ком","Справочник.Комплектующие");

  ТабКом.НоваяКолонка("Док","Документ.ПриходнаяНакладная");

  ТабКом.НоваяКолонка("Кол","Число",10,0);

  ТабКом.НоваяКолонка("Сум","Число",14,2);

// В этой таблице мы будем хранить список комплектующих в разрезе партий

// в количестве, достаточном для списания

  ТабЗн.Сортировать("1+");

  ТабЗн.ВыбратьСтроки();

  Пока ТабЗн.ПолучитьСтроку()=1 Цикл

    КомП=ТабЗн.Ком;

    КолКом=ТабЗн.Кол;

    БухИтоги.ИспользоватьСубконто(ВидыСубконто.МестоХранения,Склад,2);

    БухИтоги.ИспользоватьСубконто(ВидыСубконто.Комплектующее,КомП,2);

    БухИтоги.ИспользоватьСубконто(ВидыСубконто.ПриходнаяНакладная,,1);

    БухИтоги.ВыполнитьЗапрос(,ДатаДок,"10.2");

    БухИтоги.ВыбратьСубконто(3);

    Пока БухИтоги.ПолучитьСубконто(3)=1 Цикл

      ДокП=БухИтоги.Субконто(3);

      КолП=БухИтоги.СКД(3);




Содержание  Назад  Вперед