1С Режим Конфигуратор



Дополнение - часть 9


Для хранения выбранного нами типа списания заведем константу;

  • Создаем константу "МетодСписания" тип П.МетодСписания;

    При начале работы с программой учета надо обязательно выставлять способ списания. И в последующем не менять его. Пусть программа при начале работы проверит, выбран ли способ списания, если не выбран, то предложить выбрать, а если выбран – ничего не делать. Запрещать редактирование мы не будем, нам охота поэкспериментировать.

  • Входим в окно с деревом метаданных;
  • Меню Действия команда "Глобальный модуль";
  • Появилось окно глобального модуля. Подробнее в "Описание встроенного языка" т. 1;
  • Пишем процедуру:

    Процедура ПриНачалеРаботыСистемы()

    // предопределенная процедура, запускается при начале работы

    // в 1С:Предприятии

      Перем Значение;

    // Объявляем переменную

      Если Константа.МетодСписания.Выбран()=0 Тогда

    // если константа не заполнена

        Рез=ВвестиЗначение(Значение,"Выберите способ списания","Перечисление.МетодСписания");

    // просим выбрать способ списания. Рез=1, если выбор произведен,

    // 0 – если нет

        Если Рез=1 Тогда

          Константа.МетодСписания=Значение;

    // установим константе выбранное значение

        Иначе

          СтатусВозврата(0);

    // Мы просили выбрать значение, а Вы этого не сделали.

    // С 1С работать не будете!

    // СтатусВозврата определяет, как должно завершиться событие вызвавшее

    // предопределенную процедуру. В данном случае открытие системы должно

    // завершиться неудачей. Т.е. 1С:Предприятие закроется.

        КонецЕсли;

      КонецЕсли;

    КонецПроцедуры

  • Загрузим 1С:Предприятие и попробуем сперва отказаться от выбора, а потом выбрать FIFO. Посмотрим значения констант;
  • Создадим две приходные накладные на Склад №3 с одинаковым товаром и сортом и количеством, но с разной ценой прихода. Пусть это будет кефир первого сорта по 20 штук в накладной №6 по цене 6.00 а в накладной №7 по 7.00, яблоки первого сорта по 50 штук в накладной №6 по цене 17.00 а в накладной №7 по 19.00 и яблоки второго сорта по 50 штук в накладной №6 по цене 16.00 а в накладной №7 по 16.40. Накладная №6 должна быть от 06.10.2000, а №7 от 07.10.2000;



  • Содержание  Назад  Вперед