1С Режим Конфигуратор



Дополнение


Товар

Товар

С.Номенклатура

СтЦенаП

Старая цена прихода

Число 7.2

ЦенаП

Новая цена прихода

Число 7.2

СтЦенаР

Старая цена расхода

Число 7.2

ЦенаР

Новая цена расхода

Число 7.2

  • Новый документ;
  • Идентификатор – "ИзменениеЦен", Синоним – "Изменение цен", Комментарий – "изменение цен товара";
  • Документ будет проводиться и перепроводиться;
  • Новый журнал – "ИзменениеЦен";
  • В окне свойств документа заполним позиции согласно таблицы;
  • Создадим форму документа;
  • Графы "СтЦенаП" и "СтЦенаР" – сделаем недоступными;
  • На поле ввода "Товар" повесим формулу ВыбТовар();
  • На поле ввода "ЦенаП" повесим формулу ЦенаП();
  • В модуль формы добавим две процедуры:

    Процедура ВыбТовар()

      СтЦенаП=Товар.ЦенаП.Получить(ДатаДок);

      ЦенаП=Товар.ЦенаП.Получить(ДатаДок);

      СтЦенаР=Товар.ЦенаР.Получить(ДатаДок);

      ЦенаР=Товар.ЦенаР.Получить(ДатаДок);

    // Получаем значения периодических реквизитов справочника на дату документа

    КонецПроцедуры

    //-----------------------------------------------

    Процедура ЦенаП()

      ЦенаР=Окр(ЦенаП*(1+(Константа.ПроцентНаценки/100)),2,1);

    КонецПроцедуры

  • Перейдем к модулю документа;
  • Напишем процедуру обработки проведения документа:

    Процедура ОбработкаПроведения()

      ВыбратьСтроки();

      Пока ПолучитьСтроку()=1 Цикл

        УстановитьРеквизитСправочника(Товар,"ЦенаП",ЦенаП);

        УстановитьРеквизитСправочника(Товар,"ЦенаР",ЦенаР);

    // Мы указываем периодические реквизиты элемента справочника,

    // указанного в поле Товар и значения, которые они будут теперь иметь

      КонецЦикла;

    КонецПроцедуры

  • Сохраним конфигурацию;
  • Загрузим 1С:Предприятие;
  • Введем новый документ "Изменение цен" №1 от 04.10.2000;
  • В многострочную часть занесем товар "МПР-0342" (Кефир);
  • Укажем ему новую цену поступления – 6.50;
  • Цена реализации изменилась, и составила теперь – 8.78;



  • Содержание  Назад  Вперед