1С Режим Конфигуратор


Дополнение


Товар

Товар

С.Номенклатура

СтЦенаП

Старая цена прихода

Число 7.2

ЦенаП

Новая цена прихода

Число 7.2

СтЦенаР

Старая цена расхода

Число 7.2

ЦенаР

Новая цена расхода

Число 7.2

  1. Новый документ;
  2. Идентификатор – "ИзменениеЦен", Синоним – "Изменение цен", Комментарий – "изменение цен товара";
  3. Документ будет проводиться и перепроводиться;
  4. Новый журнал – "ИзменениеЦен";
  5. В окне свойств документа заполним позиции согласно таблицы;
  6. Создадим форму документа;
  7. Графы "СтЦенаП" и "СтЦенаР" – сделаем недоступными;
  8. На поле ввода "Товар" повесим формулу ВыбТовар();
  9. На поле ввода "ЦенаП" повесим формулу ЦенаП();
  10. В модуль формы добавим две процедуры:

    Процедура ВыбТовар()

      СтЦенаП=Товар.ЦенаП.Получить(ДатаДок);

      ЦенаП=Товар.ЦенаП.Получить(ДатаДок);

      СтЦенаР=Товар.ЦенаР.Получить(ДатаДок);

      ЦенаР=Товар.ЦенаР.Получить(ДатаДок);

    // Получаем значения периодических реквизитов справочника на дату документа

    КонецПроцедуры

    //-----------------------------------------------

    Процедура ЦенаП()

      ЦенаР=Окр(ЦенаП*(1+(Константа.ПроцентНаценки/100)),2,1);

    КонецПроцедуры

  11. Перейдем к модулю документа;
  12. Напишем процедуру обработки проведения документа:

    Процедура ОбработкаПроведения()

      ВыбратьСтроки();

      Пока ПолучитьСтроку()=1 Цикл

        УстановитьРеквизитСправочника(Товар,"ЦенаП",ЦенаП);

        УстановитьРеквизитСправочника(Товар,"ЦенаР",ЦенаР);

    // Мы указываем периодические реквизиты элемента справочника,

    // указанного в поле Товар и значения, которые они будут теперь иметь

      КонецЦикла;

    КонецПроцедуры

  13. Сохраним конфигурацию;
  14. Загрузим 1С:Предприятие;
  15. Введем новый документ "Изменение цен" №1 от 04.10.2000;
  16. В многострочную часть занесем товар "МПР-0342" (Кефир);
  17. Укажем ему новую цену поступления – 6.50;
  18. Цена реализации изменилась, и составила теперь – 8.78;



  19. - Начало -  - Назад -  - Вперед -



    Книжный магазин